Eagle Time
Downtime Warning - A Tale of Maintenance Past - Printable Version

+- Eagle Time (http://eagle-time.com)
+-- Forum: Administration (http://eagle-time.com/forumdisplay.php?fid=2)
+--- Forum: Eagle Time Forums (http://eagle-time.com/forumdisplay.php?fid=3)
+--- Thread: Downtime Warning - A Tale of Maintenance Past (/showthread.php?tid=2510)

Pages: 1 2


Downtime Warning - A Tale of Maintenance Past - Pinary - 08-06-2017

So hey, there's this thing called "updates" we need to do, and we're going to be doing it somewhat soon.

This coming weekend, August 12th and 13th, we'll be messing with things for a while, and there'll be some time during that with-messing that the forums will be off.

We do have backups and such, so in the event of catastrophic update failure, we'll probably be fine. Probably. Maybe.

While we do these things, we'll be keeping people up to date in the Discord. Want up-to-the-minute status reports on exactly what's going on? ...I mean, that's a bit much, but you can hit Schazer or I up on Discord and we'll probably give you something, at least.

If there's anything specific you think we should look at while we do this, some time this week would be a good time to prod us about it. We'll be updating both the platform (version of PHP, SQL, etc) and the software (MyBB), so this is as good a time as any to look at possible additional tweaks.


RE: DOWNTIME WARNING - Upcoming Maintenance - Dragon Fogel - 08-06-2017

Is it perhaps possible to fix the threads that are miscounting replies and therefore produce an error when the forum thinks they hit a new page? I made a list of all the affected threads way back when, it should be somewhere in this subforum and I can dig it up if you think there's a chance of actually fixing this.

The current Post Making Contest thread is also having a different postcount-related issue where it doesn't acknowledge the existence of the most recent page until three posts in. Again, no idea on the details, but it is a currently unresolved issue so it would be nice to do something about it if possible.


RE: DOWNTIME WARNING - Upcoming Maintenance - a52 - 08-06-2017

Can you fix the "FUCK," prefix in HAWKS IN SPACE?

This is approximately what it should look like (you can mess around with the shadow a bit, I just guessed about what it should be)

Code:
<span style="color: red;text-shadow: 0px 0px 2px firebrick;"><font face="Lucida Calligraphy" color="red"><b><i>FUCK,</i></b></font></span>



RE: DOWNTIME WARNING - Upcoming Maintenance - bigro - 08-07-2017

Are there going to be any new-and-exciting™ features?

(08-06-2017, 10:06 PM)a52 Wrote: Can you fix the "FUCK," prefix in HAWKS IN SPACE?

This is approximately what it should look like (you can mess around with the shadow a bit, I just guessed about what it should be)

Code:
<span style="color: red;text-shadow: 0px 0px 2px firebrick;"><font face="Lucida Calligraphy" color="red"><b><i>FUCK,</i></b></font></span>

Don't fix this.


RE: DOWNTIME WARNING - Upcoming Maintenance - Mirdini - 08-08-2017

FUCK, is a feature, not a bug


RE: DOWNTIME WARNING - Upcoming Maintenance - Justice Watch - 08-10-2017

Can you in fact make the FUCK, code worse?


RE: DOWNTIME WARNING - Upcoming Maintenance - BRPXQZME - 08-12-2017

Imagine my shock when the current software straight up ate a baguette emoji!

Well, I’m not sure I feel too good about it being part of Unicode, but the device vendors of the world have already crossed the Rubicon.

... lemme guess. There’s already a rub icon. Melonspa


RE: DOWNTIME WARNING - Upcoming Maintenance - Infrared - 08-12-2017

[Image: tumblr_mjfb7iQopg1r09gfvo1_1280.gif]


RE: DOWNTIME WARNING - Upcoming Maintenance - Pinary - 08-12-2017

(08-06-2017, 09:44 PM)Dragon Fogel Wrote: Is it perhaps possible to fix the threads that are miscounting replies and therefore produce an error when the forum thinks they hit a new page? I made a list of all the affected threads way back when, it should be somewhere in this subforum and I can dig it up if you think there's a chance of actually fixing this.
I'm not sure if the MyBB portion of the update will address this or not, and I don't know if it'll make any related changes, so we'll have to see afterwards.

Quote:FUCK
I'm FUCK,gnostic on the issue, so I'm going to err on the side of not touching it and seeing what happens.

Also, things will be starting in 2.5-3 hours, so hold on to your pants and get ready for an exciting (read: boring) ride!


RE: DOWNTIME WARNING - Upcoming Maintenance - Pinary - 08-13-2017

Alrighty, the bulk of the update is complete! We've now moved past the main phases and into the cleanup step, which involves fixing things (like the corners of tables and some missing graphics) that the update knocked out of place. We're aiming to get these mostly done over the rest of the weekend, but if you see anything that jumps out as busted after that time, this is probably as good a place as any to drop a note and let us know.


RE: Downtime Warning - A Tale of Maintenance Past - Robust Laser - 08-13-2017

clicking on the most recent post of a subforum on the main page brings me back to the main page


RE: Downtime Warning - A Tale of Maintenance Past - Schazer - 08-13-2017

Buglog (consolidating also what people have mentioned):
  • everything has curved corners now and I Do Not Like It (the red is intentional, we have that as the forum bg color so we can see when things are messed up)
  • new topic button in subforums and new reply button in threads are plaintext instead of image
  • text sizes have gone wonky in some places like Signatures (e.g. fogel's). Edit help files to explain how they work now
  • Edit Options no longer has an option to show/hide images and videos (must be done by an admin through ACP)
  • Thread status images need updating in Search
  • ---User Control Panel---
    • Icons all need replacing
    • Saved Drafts doubles up on text when you have drafts
  • Contact Details box on user profiles has been reset
  • Broken image hotlinks now stretch avatar areas
  • Advanced Reply no longer has the box of myBB shortcuts
  • tables look Real Bad, Folks - big thanks to awkwardCarapace for helping me find a solution
  • Users who didn't have a user title have had it change to "(&nbsp;)"
  • --Inside threads and replies--
    • multiquote has upped and vanished from under posts
    • Delete button doesn't show up/no longer works
    • buttons underneath replies: for PM, Edit etc have been stripped of their images
    • Signatures no longer separated from post content by dividing line
  • A bunch of buttons like Search Thread at top and bottom of threads, Post Reply+Preview Post under the quick reply box, looked worse then I took the corners off them. will do some further improvements on this later using css3.css stylesheet and this page for reference
  • ---Pagination---:
    • Jump to page button at top of threads looks bad and doesn't work (fixed via removal as we didn't have it previously
    • Page numbers except for the one you're on have curved corners
  • ---Frontpage:---
    • Subforums on the front page no longer display read+unread posts status
    • Subforums now display on a new line underneath the heading Subforums
    • The little toggle image to show+hide forums needs replacing
    • Clicking on thread names on index.php goes to index.php instead (probably an issue with $newpost_link)
    • Times and dates displaying weirdly (showing X hours ago on front page and also in threads), compare with archived homepage
  • Annoying red bits:
    • Around announcement posts
    • around previewed posts



RE: Downtime Warning - A Tale of Maintenance Past - Dragon Fogel - 08-13-2017

Wow, that's weird.

I guess people can just click on it and see which thread they arrive in.


RE: Downtime Warning - A Tale of Maintenance Past - bigro - 08-13-2017

reply box is missing the usual box up the top with all the bbcode shortcuts


RE: Downtime Warning - A Tale of Maintenance Past - a52 - 08-13-2017

There's no bar between post content and signatures


RE: Downtime Warning - A Tale of Maintenance Past - Robust Laser - 08-13-2017

We've also got that when using the quick reply it does post but doesn't really look like it does -- the post doesn't appear on the page like it did before and it doesn't even refresh to make up for the fact that this functionality is lost.


RE: Downtime Warning - A Tale of Maintenance Past - BRPXQZME - 08-14-2017

MOH HO HO now nothing can stop baguette ?

(Nope, but now it does convert to question mark.)

((Smilies don't seem to work on click at the moment.))


RE: Downtime Warning - A Tale of Maintenance Past - Dragon Fogel - 08-15-2017

If I preview a post, there's a red border around the preview. I guess that means part of the page isn't being filled in?


RE: Downtime Warning - A Tale of Maintenance Past - Wheat - 08-16-2017

on opera, image tags and video tags do not display images or video. instead you get

Spoiler :
[Image: unknown.png]

[Image: unknown.png]

however, the [youtube]tag works.

If i use google chrome, it's not a problem.


it works now, thank you!


RE: Downtime Warning - A Tale of Maintenance Past - Wheat - 08-17-2017

never mind it's not working again. Looking into it more it only doesn't work for when I am logged into the account Wheat.

If I log out or log into another account it works just fine. I've tried changing style sheets, but that doesn't fix it. Also, selecting "Use default" under style doesn't let me have whatever stylesheet is default for that style. It only displays the white main eagle theme. I've got a feeling that might have something to do with the problem? is there a way to reset my default user settings?

e: also, figured out that it has nothing to do with the browser. I just wasn't logged in on other browsers when I went here on them so the problem didn't show up. But when logging in, the problem appeared.


and it's fixed! thank you so much!!


RE: Downtime Warning - A Tale of Maintenance Past - Dis_Aster - 08-19-2017

I've still got the same dumb problem that Wheat has, myself. Not sure why it didn't fix itself for whatever you did on that front, but nothing's changed on my end. Mind, I haven't seen if logging into another account is any different, though considering that logging out doesn't cause the problem to show up, then, I'd presume I'm probably in the same boat, so... Hell if I know why things aren't any different on my end.


RE: Downtime Warning - A Tale of Maintenance Past - Schazer - 08-20-2017

For anyone having the same issue as Wheat and Dis, it's an issue with your user settings. Prior to the update you used to be able to change this setting yourself through the UCP but now I've gotta push a button through the admin control panel?

If anyone else has this issue PM me and I can get it fixed up quicksmart until I'm able to figure out how to get the option reinstated in regular users' settings panel.


RE: Downtime Warning - A Tale of Maintenance Past - awkwardcarapace - 08-20-2017

I think this is a bug. "Saved drafts" is repeated in the control panel if there is a saved draft (like so).


RE: Downtime Warning - A Tale of Maintenance Past - a52 - 08-22-2017

The "Location" setting underneath people's profiles doesn't say "Location: <text>", it just says "<text>".

I don't know if this was always the case or not, or if it was intended, but users who have no or little personal information filled out for their user page will be missing a whole table/sections of a table completely, rather than just having a table with empty entries. (Example)


RE: Downtime Warning - A Tale of Maintenance Past - ICan'tGiveCredit - 08-22-2017

the word "location" doesn't even appear under a poster's profile pic